Skip to main content

Comments

1 comment

  • Official comment
    Chris Clark

    ZionWorx 2014 works with Windows 8.1 (all Windows versions from Vista SP2 through to Windows 10) however some configuration options which ZionWorx needs may not be set correctly. Can you please contact support@jubilatesoftware.com with your specific issue and we will assist you further.

Please sign in to leave a comment.

Powered by Zendesk